Создание формы подбора для документа

В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова:
Источник материала
15:11 14.12.2016



Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Дети-билингвы: невозможное возможно?

Дети-билингвы: невозможное возможно?

Дети, говорящие на нескольких языках — это то, о чем мечтают многие родители. Помимо тех детей, которые вынуждены с рождения говорить на нескольких языках (проживающие за границей, имеющие ...
Печать на пактах: подарочные и повседневные пакеты.

Печать на пактах: подарочные и повседневные пакеты.

Основная функция, которой наделяются все пакеты – упаковки и перенос различных вещей. Большее распространение получили полиэтиленовые пакеты с различными изображениями. Это могут быть как пакеты майки...
Вкусные рецепты: Итальянская пасхальная коломба, Зразы"ПО-КИЕВСКИ", кексы с начинкой (вариант)

Вкусные рецепты: Итальянская пасхальная коломба, Зра...

Итальянская пасхальная коломбаСложите изюм, цукаты в миску, залейте вином и дайте настояться полтора часа.Слейте вино, цукаты и изюм обваляйте в муке. Приготовьте опару:в миске смешайте молоко теплое ...
Оформление зала для проведения свадьбы  шарами

Оформление зала для проведения свадьбы шарами

Чаще всего молодожены имеют свое представление об оформлении свадебного зала. Представление это формируется на основе увиденного ранее. Традиционно свадебное место оформляется аркой из шаров, надутых ...
Что умеет идеальная модель мультиварки? Знакомьтесь, Supra MCS-5201

Что умеет идеальная модель мультиварки? Знакомьтесь,...

Считается, что сам себя не похвалишь — никто не похвалит. Но иногда ты настолько хорош, что тебя хвалят все. Особенно если ты — новинка в мире мультиварок Supra. Итак, здравствуй...
Как выглядеть модно и стильно? Искусство сочетать

Как выглядеть модно и стильно? Искусство сочетать

Цвет является не соучастником, а главным героем модного шоу. Сочетать в одном наряде сразу несколько цветов — целое искусство, но, используя эти простые подсказки, вы легко освоите главную ...
Самое интересное

Этапы разработки сайта: шаг за шагом

«Кто владеет информацией - тот владеет миром». Очень мудрую фразу сказал когда-то один философ. И эт...

Способы защиты печатей от нежелательного копирован

Государственные печати должны иметь по госту 3 степени защиты. Для обычных печатей наличие защиты не...

Онлайн кинотеатры против реальных кинотеатров.

После изнурительного трудового дня человек нередко мечтает прийти домой, поужинать, принять расслаб...

Вкусные рецепты: Торт чернично-фруктовый, печень п

Торт чернично-фруктовыйвзбить тесто: яйца с сахаром, добавить муку, крахмал, ваниль в форму для запе...

Реклама - обман или искусство?

«Только сегодня!. . Скидка на наш товар 50%! При заказе одной пары — вторая в подар...

Кто такой байбак, или Где найти живой реликт?

На покатом склоне холма видны белесые пятна — здесь мел выходит на поверхность, и рядом з...

Белгородский мошенник обокрал известного рок музык

Из последних источников от коллег из Белгорода стало известно, что некий гражданин Виктор Давыденко...

Запорная арматура: основные типы и опции электрома

Клапаны с электромагнитом держат под контролем течение жидкости и газа по трубам. Позиция запирающег...

Использование трафарета при росписи стен

Меловые потолки и стены уходят во вчерашний день. Актуален тон, который сможет совершить переворот п...

Волнующий Байкал

Ценители уединенного отдыха на фоне потрясающих пейзажей обязательно должны увидеть Байкал осенью. Г...



О информационном портале:

Наш портал является ресурсом, который включает в себя широкий перечень познавательных и интересных статей. Каждый посетитель найдет для себя что-нибудь полезное. Адаптированный дизайн позволяет вам максимально быстро находить необходимую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти необходимую информацию стало совершенно просто.

Мы собрали для вас информативные и отличные статьи. У нас сайте вы найдете ответы на необходимые для вас вопросы. Упрощенная система поиска позволяет вам мгновенно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск нужной информации будет занимать у вас считанные секунды.