Создание формы подбора для документа

В данной статье речь пойдет о создании формы подбора Номенклатуры, открываемой из формы документа для подбора необходимых позиций. Форма будет создана на основе общих форм и будет состоять из трех списков. Первый список будет отображать дерево значений номенклатуры, второй - непосредственно список номенклатуры, а в третьем будут отображаться выбранные значения. Для начала зайдем в документ, создадим кнопку "Подбор" и команду на кнопку. Теперь добавим действие на эту команду в котором пропишем код, открывающий форму подбора: &НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("ОбщаяФорма. ФормаПодбора");
КонецПроцедуры
Далее закрываем форму документа (к ней мы вернемся чуть позже) и создаем новую общую форму "ФормаПодбора":

Далее добавляем таблицу на форму и реквизит к таблице. Тип данных реквизита будет "ДинамическийСписок". В свойствах реквизита в разделе Объект поставим галочку - "Произвольный запрос" и нажмем на ссылку Настройка списка: В появившейся форме нам необходимо будет написать запрос который будет отображаться в таблице "Дерево". Текст запроса будет выглядеть так: ВЫБРАТЬ
Номенклатура. Наименование КАК Группа
ИЗ
Справочник. Номенклатура КАК Номенклатура
ГДЕ
Номенклатура. ЭтоГруппа Теперь нужно немного изменить настройки для таблицы Дерево, точнее изменить кое какие свойства отображения нашего древовидного списка: 1. Установим галочку на свойство ТолькоПросмотр 2. Установим галочку на свойство РежимВыбора 3. ПоложениеКоманднойПанели - Нет 4. Отображение - Дерево 5. Режим выделения - Одиночный 6. Начальное отображение дерева - Раскрывать верхний уровень 7. Выбор групп и элементов - Группы 8. РазрешитьВыборКорня - Галочка Посмотрим что у нас получилось:

Неплохо. Следующим шагом будет создание таблицы где будет отображаться сама номенклатура. Создадим на форме еще отдну таблицу Список и добавим реквизит с таким же названием. Как и в случае с реквизитом Дерево повторяем те же манипуляции, т. е. тип - ДинамическийСписок, произвольный запрос - Да. Открываем форму редактирования запроса. Тут придется написать запрос чуточку сложнее (подробности можно посмотреть в конструкторе запросов): ВЫБРАТЬ
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка
ИЗ
Справочник. Номенклатура КАК НоменклатураСписок
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений. Цены. СрезПоследних КАК ЦеныСрезПоследних
ПО НоменклатураСписок. Ссылка = ЦеныСрезПоследних. Номенклатура. Ссылка
ГДЕ
НоменклатураСписок. Родитель. Ссылка В(&Группа)
СГРУППИРОВАТЬ ПО
ЦеныСрезПоследних. Цена,
НоменклатураСписок. Код,
НоменклатураСписок. Ссылка Плюс нужно создать событие формы ПриСозданииНаСервере и прописать в нем наш фильтр "Группа": &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры Форма почти готова. Осталось связать наши таблицы: Дерево и Список. Для этого нужно будет создать еще несколько событий для таблицы Дерево: &НаКлиенте
Процедура ОбновитьСписок()
Список. Параметры. УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
Группа = Значение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Группа = ВыбранноеЗначение;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры &НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
Группа = Строка;
ОбновитьСписок();
КонецПроцедуры
&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
Группа = Элемент. Родитель;
ОбновитьСписок();
КонецПроцедуры Наша форма почти готова: Ну и наконец добавим третий список (тип данных - ТаблицаЗначений), в который добавим 2 колонки - Номенклатура и Цена: а в таблице "Список" добавим событие "Выбор": &НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)

ТекущаяСтрока = Элемент. ТекущиеДанные;
НоваяСтрока = Отобранные. Добавить();
НоваяСтрока. Номенклатура = ТекущаяСтрока. Ссылка;
НоваяСтрока. Цена = ТекущаяСтрока. Цена;

КонецПроцедуры Теперь необходимо чтобы эта форма возвращала отобранные значения, обратно в форму документа. Для этого создадим новую кнопку "ОК" и создадим новую команду с таким же названием. Событие будет выглядеть так: &НаКлиенте
Процедура ОК(Команда)
Закрыть(ЗаписатьВХранилище());
КонецПроцедуры
а функция ЗаписатьВХранилище будет такая: &НаСервере
Функция ЗаписатьВХранилище()
Возврат ПоместитьВоВременноеХранилище(Отобранные. Выгрузить());
КонецФункции
Откроем опять форму нашего документа и исправим процедуру Подбор, добавив процедуру получения данных из временного хранилища: &НаСервере
Процедура ПолучитьЗапасыИзХранилища(АдресВХранилище)

ВременнаяТаблица = ПолучитьИзВременногоХранилища(АдресВХранилище);

Для Каждого ЗагружаемаяСтрока Из ВременнаяТаблица Цикл
СтрокаТЧ = Объект["Товар"]. Добавить();
СтрокаТЧ. Номенклатура = ЗагружаемаяСтрока. Номенклатура;
СтрокаТЧ. Цена = ЗагружаемаяСтрока. Цена;
КонецЦикла;

КонецПроцедуры
&НаКлиенте
Процедура Подбор(Команда)

ФормаПодбора = ПолучитьФорму("ОбщаяФорма. ФормаПодбора");
АдресВХранилище = ФормаПодбора. ОткрытьМодально();
Если ЗначениеЗаполнено(АдресВХранилище) Тогда
ПолучитьЗапасыИзХранилища(АдресВХранилище);
КонецЕсли;

КонецПроцедуры Наконец наша форма подбора готова:
Источник материала
15:11 14.12.2016



Отзывы и комментарии
Ваше имя (псевдоним):
Проверка на спам:

Введите символы с картинки:



Все что нас окружает: излучение!

Все что нас окружает: излучение!

Если дать краткое определение излучению, то можно сказать, что это поток волн, несущих энергию. Если мы проведем рукой около горящей свечи, мы почувствуем, как излучается тепло. Если посмотрим на солн...
Какой писатель мог бы стать одним из первых и успешных польских предпринимателей? Януш Пшимановский

Какой писатель мог бы стать одним из первых и успешн...

Наверное, он мог бы стать одним из самых успешных польских бизнесменов. Но… Не стал. И поэтому мы знаем Януша Пшимановского… Нет, наверное, не совсем так. Сейчас имя этого польского...
Зачем редактор правит статью, начиная аж с заголовка?

Зачем редактор правит статью, начиная аж с заголовка...

Каждый автор хочет донести свою точку зрения до читателей в максимально привычной для него форме. Когда журналист или копирайтер приносит свою статью к редактору, то часто сталкивается с таким неприят...
Заправка лазерных картриджей сегодя.

Заправка лазерных картриджей сегодя.

Лет 10 назад, когда у нас еще не было лазерных принтеров, мы пользовались печатью на струйных принтерах. О качестве печати между лазерными принтерами и струйными отдельный разговор, мнений по этому по...
Обратная сторона дефицита специалистов

Обратная сторона дефицита специалистов

Дефицит квалифицированных специалистов — вот проблема, которая давно требует решения. Но беда не приходит одна: обратной стороной нехватки кадров становится массовая текучесть персонала. Одним из осно...
Озеро Арей и его происхождение. Всегда ли права наука?

Озеро Арей и его происхождение. Всегда ли права наук...

Арей — озеро, расположенное в Забайкальском крае в 240 км от краевого центра в седловине между Малханским и Яблоновым хребтом на высоте 996 метров над уровнем моря. Длина озера около 3...
Стоит прочесть

Вкусные рецепты: Фаршированный батон, А-ля гамбург

Фаршированный батонПорей очистить и отделить зеленые стебли, 5 минут бланшировать в подсоленной воде...

Стрижка собак

В вашем доме появился новый питомец – породистая собака с прекрасной шерстью. Но спустя какое-то вре...

Стоит ли кота называть Мерзавцем и как устроить ег

— Ну что, сводил кота к ветеринару?  — Сводил.  — И что, он у тебя ...

Инсулинорезистентность как основная причина набора

Инсулинорезистентность Одна из главных причин постоянного сильного чувства голода – нарушение уг...

10 лучших приёмов работы диджея с публикой

1. Тщательный подбор музыкального материалаПеред игрой ответь на следующие вопросы. Какие эмоции ты ...

Прыжки в Counter Strike 1.6

Strafe-JumpБазовый прыжок в Counter Strike 1. 6, без которого вы не сможете выполнить практически ни...

Интернет-магазин детских товаров: одежда для новор

Мы рады приветствовать Вас в интернет-магазине детских товаров! Родители размышляют, какую детскую о...

Когда можно брать микрозайм?

Микрозайм — небольшая сумма денег, которую можно взять в долг у финансовой организации на...

Химчистка ковров и мебели

Химическая чистка мебели и чистка ковров - важные этапы в системе клининга. Ведь клининг - это не пр...

Белгородский мошенник обокрал известного рок музык

Из последних источников от коллег из Белгорода стало известно, что некий гражданин Виктор Давыденко...



Развивая портал:

Наш портал является ресурсом, который включает в себя широкий перечень познавательных и интересных статей. Каждый посетитель найдет для себя что-нибудь полезное. Адаптированный дизайн позволяет вам максимально быстро находить необходимую информацию. Самые разнообразные тематические статьи дают возможность вам совершенствоваться в той или иной сфере. Быть более начитанным и грамотным. Современный дизайн сайта позволяет просматривать статьи на всех существующих планшетах. Теперь найти необходимую информацию стало совершенно просто.

Мы собрали для вас информативные и отличные статьи. У нас сайте вы найдете ответы на необходимые для вас вопросы. Упрощенная система поиска позволяет вам мгновенно отыскать нужную информацию. Адаптированный дизайн позволяет вам просматривать информацию на абсолютно любых электронных устройствах. Теперь, поиск нужной информации будет занимать у вас считанные секунды.